Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
air7789
16.08.2021 05:17 •
Информатика
50 ! написать программу которая просит ввести 10 чисел и находит сумму всех чисел,которые больше 0 из ряда введенных для pascal abc
Показать ответ
Ответ:
egorlapin2004
07.10.2020 19:47
Program abc;
var a, summa:integer;
begin
summa:=0;
writeln('Введите 10 чисел');
for i:integer:=1 to 10 do begin
readln(a);
if a>0 then summa:=summa+a;
end;
writeln(summa)
end.
0,0
(0 оценок)
Ответ:
spilberg3
07.10.2020 19:47
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:= ReadArrInteger(10);
Writeln(a.Where(t->t>0).Sum);
end.
Пример:
0
12
2
3
5
6
1
2
5
6
42
0,0
(0 оценок)
Популярные вопросы: Информатика
СнежанаВолк
04.06.2023 06:12
Вычисли сумму чисел в ms excel. 1. 291; 22; 1048; 72,1 2. 291; 22; 1048; 72,1; 59...
кекай
21.09.2022 08:54
Переведите в биты: 57кбайт 57 мбайт 57 гигабайт...
55636906ррлиод
31.05.2020 18:07
Сопоставьте Укажите соответствие для всех 4 вариантов ответа: 1) Магнитосфера 2) Магнитная буря 3) Признак магнитной аномалии 4) Одно из следствий солнечного ветра __ Резкое увеличение...
seregatarlykov
24.02.2021 10:09
Загальна назва солей , утворених фенолом...
spikeeesz
31.05.2020 18:07
Заполните таблицу животноводство...
Kvasya07
31.05.2020 18:07
Выбери химический элемент с наиболее выраженными неметаллическими свойствами : иод хлор фтор...
Howcould
31.05.2020 18:07
Запишите предложения. Вставьте, где необходимо, запятые. Укажите те, в которых сравнительный оборот не обособляется. Укажите, каким выражено сравнение в первом предложении. В чём...
vakhtinanelli
31.05.2020 18:07
Известно что tg a/6 =0.5 найдите tg a/3...
526424244241242
31.05.2020 18:07
Что хотят Пиа Рафик Запиши предложение Pia mochte Rucksack...
ооооооолл
23.05.2021 18:15
Франция Ұлттық кітапханасы мәтінін редакциялау.6-сыныпөтініш тезірек...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var a, summa:integer;
begin
summa:=0;
writeln('Введите 10 чисел');
for i:integer:=1 to 10 do begin
readln(a);
if a>0 then summa:=summa+a;
end;
writeln(summa)
end.
// Внимание! Если программа не работает, обновите версию!
begin
var a:= ReadArrInteger(10);
Writeln(a.Where(t->t>0).Sum);
end.
Пример:
0
12
2
3
5
6
1
2
5
6
42