Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
salievtrofim20
07.03.2020 03:58 •
Информатика
7. дан массив а из 20 элементов. заменить отрицательные эле-менты массива на среднее арифметическое элементов массива. результат вывести на печать.
Показать ответ
Ответ:
chelsea6
21.07.2020 22:44
Var Sr:real;
i,n:integer;A:Array[1..20] of real;
beginfor i:=1 to 20 do begin
A[i]:= random(100)-50;
write(A[i]:5);
Sr:= Sr + A[i];
end;
Sr:= Sr/20;
Writeln(' Sr= ', Sr);
for i:=1 to 20 do begin
if A[i] < 0 then A[i]:= Sr;
write(A[i]:5);
end;end.
0,0
(0 оценок)
Популярные вопросы: Информатика
g8trouble
08.07.2020 01:06
Рассмотрите элементы блок-схемы алгоритма. Установите соответствие ЦиклНачало и конецДействиеRO...
Iriska91l23
30.04.2020 20:58
УМОЛЯЮ ЭТО СОР ТОЛЬКО МОЖНО БЕЗ СПАМА НОРМ ОТВЕТ . КАЗАХСКИЙ ЯЗЫК НЕЧАЙНО НА ИНФОРМАТИКУ НАЖАЛ СОРРИ...
DreamEvilDead
06.02.2021 09:45
Контрольные во В каком пункте меню сосредоточено большинство операций по форматированию таблиц? 2. Как называется диаграмма, созданная на одном рабочем листе с таблицей? 3.Перечислите...
Ингуш03
06.02.2021 09:45
Автомат получает на вход четырёхзначное натуральное число и строит новое число по следующему алгоритму: 1. вычисляются суммы первой и второй, второй и третьей и третьей и четвёртой...
ZlushiyPlayar
18.03.2022 19:56
Коли використовується цикл з передумовою?...
valeriya210322
11.06.2022 16:58
Кто-нибудь кто хорошо разбирается в pascal 1.нарисовать круг, разделённый на n одинаковых частей, окрашенных в разный цвет. количество частей n вводится с клавиатуры. 2.нарисовать...
syromyatnikovа
24.10.2021 10:15
Удрессировщика вольки есть волшебная палочка и один лев. за один взмах палочки количество львов или удваивается, или утраивается или увеличивается на 1. к концу представления...
ЧеПацаныАниме1
27.09.2021 03:48
, это тест по информатике ...
Маликакот
26.10.2020 09:26
Известны стоимости каждого из восьми предметов в двух наборах. Какой из наборов более дешевый? Построить блок-схему )...
LolGameHD
22.05.2021 03:29
НУЖНО Определите значение переменной «а» после выполнения фрагмента программы:а е 10if a 5:а на + 12else:ана - 7...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
i,n:integer;A:Array[1..20] of real;
beginfor i:=1 to 20 do begin
A[i]:= random(100)-50;
write(A[i]:5);
Sr:= Sr + A[i];
end;
Sr:= Sr/20;
Writeln(' Sr= ', Sr);
for i:=1 to 20 do begin
if A[i] < 0 then A[i]:= Sr;
write(A[i]:5);
end;end.