В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Fastik26
Fastik26
03.01.2022 21:20 •  Информатика

7. На вход программе подается натуральное число. Каких цифр в числе больше четных или нечетных. В ответ выведите 1, если больше нечетных и 0, если четных и 2, если их количество одинаково.Питон

Показать ответ
Ответ:
alena13gerda
alena13gerda
13.10.2020 14:35

num = input()

n = len(num)

odd = 0

noodd = 0

while i < len(num):

   if(int(num[i]) % 2 == 0):

       odd = odd + 1

   else :

       noodd = noodd + 1

if(odd == noodd):

   print(2)

elif(odd > noodd):

   print(0)

else :

   print(1)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота