В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
krll333
krll333
30.05.2022 08:24 •  Информатика

70 ! надо написать программу на языке паскаль, которая вычисляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел. всё это надо написать одной программой через оператора repeat. не с !

Показать ответ
Ответ:
veronika121416
veronika121416
01.10.2020 13:03

program raf105;

var

 n,i,a,b,c,d,sqrt: integer;

begin

 write('Введите n: ');

 readln(n);

 repeat

   i:= i+1;

   a:= a+i;

   sqrt:= i*i;

   b:= b+sqrt;

   if i mod 2 = 0

     then c:= c+i;

   if (i >= 10) and (i <= 99)

     then d:= d+i;

 until i = n;

 writeln('а) ',a);

 writeln('б) ',b);

 writeln('в) ',c);

 writeln('г) ',d);

end.

PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота