70 напишите программу для решения : торт весом т кг режут на порции. каждая порция торта весит р грамм. сколько гостей можно угостить тортом? программа должна запрашивать ввод необходимых данных и выводить ответ, который должен являться решением . через программу питон 3.5.2 пришлите файл
на Free Pascal
Объяснение:
var
a : integer;
n, i, big, nc, ncount : integer;
begin
writeln('Введите количество чисел :');
readln(n);
big := 0;
nc := 0;
ncount := 0;
for i := 1 to n do begin
writeln('Введите ', i, ' число:');
readln(a);
if a>20 then
big := big + a;
if (a mod 2) <> 0 then begin
nc := nc + a;
inc(ncount);
end;
end;
writeln('Сумма чисел > 20 = ', big);
writeln('Среднее арифметическое ',ncount,' нечётных чисел =', nc/ncount:2:2);
end.
смотри объяснение!
Объяснение:
1 поколение - ламповые машины ; 2 поколение - полупроводниковые машины на транзисторах ; 3 - вычислительные системы на большой интегральной схеме ; 4 - мини компьютеры на интегральных схемах .
4 Одним из первых устройств, облегчающих вычисления, можно считать абак. Следующим этапом люди изобрели аналоговый компьютер. А впоследствии и до сих пор мы пользуемся цифровым компьютером.
5 Робот является одним из признаков развития вычислительной техники пятого поколения, потому что в основе его лежит искусственный интеллект.