В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nenovaolya
nenovaolya
16.01.2022 03:54 •  Информатика

70 ! нарисовать куб в паскаль, используя line/rectangle и закрасить разными цветами каждую грань. напишите программу как это сделать​

Показать ответ
Ответ:
JaanB
JaanB
28.07.2020 10:15

3.1. 200

3.2. for i:1 to 200 do  a[i]:=random(100)-50;

3.3. - \frac{2^{32} }{2} ... \frac{2^{32} }{2}  (т.к 4 байта)

либо -50 ... 50 (рандом)

3.4. Чтобы значения не "склеивались", т.к было расстояние между элементами

4.1. a[номер элемента] = значение элемента "перенос строки"

4.2. Для подсчета количества элементов равных 20

4.3.  k - она объявлена, но не используется

4.4.  Количество элементов равных 20

5.

var

a:array[1..300] of integer;

i,n,p,k: integer;

begin

p:=0;

n:=0;

randomize;

for i:1 to 300 do

a[i]:=random(40)-20;

for i:=1 to 300 do

write(a[i],' ');

writeln;

for i:=1 to 300 do

if a[i]=p then

begin

writeln('a[',i,']=',a[i]);

n:=n+1;

end;

writeln;

writeln(n);

end.

ꟷꟷꟷꟷꟷꟷ      

Не забывайте сказать " "! и, если ответ удовлетворил, то выберите его как "Лучший"    

Бодрого настроения и добра!        

Успехов в учебе!

0,0(0 оценок)
Ответ:
69supreme
69supreme
13.10.2022 08:08

задание 1:

использовать Робот

алг

нач

цел с=0

нц

вверх

если слева стена то закрасить; с:=1 всё

кц при с=1 и слева свободно

нц пока снизу свободно

если слева стена то с:=1 иначе с:=0 всё

вниз

если с=1 и слева стена то закрасить всё

кц

нц

если снизу свободно то с:=0 всё

вправо

если снизу стена то

закрасить

если с=0 то с:=2 всё

всё

кц при с=2 и снизу свободно

кон

задание 2:

использовать Робот

алг

нач

цел с=0

нц

влево

если сверху стена то закрасить; с:=1 всё

кц при с=1 и сверху свободно

нц пока справа свободно

если сверху стена то с:=1 иначе с:=0 всё

вправо

если с=1 и сверху стена то закрасить всё

кц

нц

если справа свободно то с:=0 всё

вниз

если справа стена то

закрасить

если с=0 то с:=2 всё

всё

кц при с=2 и справа свободно

кон


Составьте, , программы для робота в кумире на 2 . ​
Составьте, , программы для робота в кумире на 2 . ​
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота