В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
bes10
bes10
19.12.2022 10:20 •  Информатика

8 кл Дано описание массива С:

char C[3] = { ''A'', ''1'', ''Ю'' };

Чему равно значениеэлемента С[2]?

Показать ответ
Ответ:
ВладыкаМор
ВладыкаМор
03.03.2022 08:49

Відповідь:

Для начала, Пайтон – язык со строгой динамической типизацией. Что это означает?

Есть языки со строгой типизацией (pascal, java, c и т.п.), у которых тип переменной определяется заранее и не может быть изменен, и есть языки с динамической типизацией (python, ruby, vb), в которых тип переменной трактуется в зависимости от присвоенного значения.

Языки с динамической типизацией можно разделить еще на 2 вида. Строгие, которые не допускают неявного преобразования типа (Пайтон) и нестрогие, которые выполняют неявные преобразования типа (например VB, в котором можно легко сложить строку '123' и число 456).

Разобравшись с классификацией Пайтона, попробуем немного «поиграть» с интерпретатором.

>>> a = b = 1

>>> a, b

(1, 1)

>>> b = 2

>>> a, b

(1, 2)

>>> a, b = b, a

>>> a, b

(2, 1)

Таким, образом мы видим что присваивание осуществляется с знака =. Присвоить значение можно сразу нескольким переменным. При указании интерпретатору имени переменной в интерактивном режиме, он выводит ее значение.

Следующее, что необходимо знать – как строятся базовые алгоритмические единицы – ветвления и циклы. Для начала, необходима небольшая справка. В Пайтоне нет специального ограничителя блоков кода, их роль выполняют отступы. То есть то что написано с одинаковым отступом – является одним командным блоком. Поначалу это может показаться странным, но после легкого привыкание, понимаешь что эта «вынужденная» мера позволяет получать очень читабельный код.

Итак условия.

Условие задается с оператора if, который заканчивается «:». Альтернативные условия которые будут выполняться если первая проверка «не » задаются оператором elif. Наконец else задает ветку, которая будет выполнена если ни одно из условий не подошло.

Обратите внимание, что после ввода if интерпретатор с приглашения «...» показывает что он ожидает продолжения ввода. Чтобы сообщить ему что мы закончили, необходимо ввести пустую строку.

(Пример с ветвлениями почему-то рвет разметку на хабре, не смотря на танцы с тегами pre и code. Простите за неудобство, я его кинул сюда pastebin.com/f66af97ba, если кто-то подскажет что не так — буду очень признателен)

Циклы.

Простейшим случаем цикла является цикл while. В качестве параметра он принимает условие и выполняется до тех пор, пока оно истино.

Вот маленький пример.

>>> x = 0

>>> while x<=10:

...     print x

...     x += 1

...

0

1

2

10

Обратите внимание что поскольку и print x и x+=1 написаны с одинаковым отступом, они считаются телом цикла (помните что я говорил про блоки? ;-) ).

Второй вид циклов в Пайтон – цикл for. Он аналогичен циклу foreach других языков. Его синтаксис условно таков.

for переменная in список:

команды

Переменной будут присваиваться по очереди все значения из списка (на самом деле там может быть не только список, но и любой другой итератор, но не будем пока этим забивать голову).

Вот простой пример. В роли списка будет выступать строка, которая является ничем иным как списком символов.

>>> x = "Hello, Python!"

>>> for char in x:

...     print char

...

H

e

l

!

Таким образом мы можем разложить строку по символам.

Что же делать если нам нужен цикл, повторяющийся определенное число раз? Очень просто, на придет функция range.

На входе она принимает от одного до трех параметров, на выходе возвращает список чисел, по которому мы можем «пройтись» оператором for.

Вот несколько примеров использования функции range, которые объясняют роль ее параметров.

>>> range(10)

[0, 1, 2, 3, 4, 5, 6, 7, 8, 9]

>>> range(2, 12)

[2, 3, 4, 5, 6, 7, 8, 9, 10, 11]

>>> range(2, 12, 3)

[2, 5, 8, 11]

>>> range(12, 2, -2)

[12, 10, 8, 6, 4]

И маленький пример с циклом.

>>> for x in range(10):

...     print x

...

0

1

2

9

Ввод-вывод

Последнее, что следует знать перед тем как начать использовать Пайтон полноценно – это как осуществляется в нем ввод-вывод.

Для вывода используется команда print, которая выводит на печать все свои аргументы в удобочитаемом виде.

Для ввода с консоли используется функция raw_input(приглашение), которая выводит на экран приглашение и ожидает ввода пользователя, возвращая то что ввел пользователь в виде своего значения.

x = int(raw_input ("Введи число:"))

print "Квадрат этого числа составляет ", x * x

Внимание! Несмотря на существование функции input() схожего действия, использовать ее в программах не рекомендуется, так как интерпретатор пытается выполнить вводимые с ее синтаксические выражения, что является серьезной дырой в безопасности программы.

Пояснення:

0,0(0 оценок)
Ответ:
GOLUM34ruS
GOLUM34ruS
14.02.2022 00:42

#include <iostream>

using namespace std;

int main() {

   int n, m;

   cin >> n >> m;

   int a[10][10] = { {1,1,1,1,1,1,1,1,1,1},{1,2,3,4,5,6,7,8,910}, {1,3,6,10,15,21,28,36,45,55},{1,4,10,20,35,56,84,120,165,220},{1,5,15,35,70,126,210,330,495,715}, {1,6,21,56,126,252,462,792,1287,2002}, {1,7,28,84,210,462,924,1716,3003,5005}, {1,8,36,120,330,792,1716,3432,6435,11440},{1,9,45,165,495,1287,3003,6435,12870,24310},{1,10,55,220,715,2002,5005,11440,24310,48620} };

   cout << a[n - 1][m - 1];

   return 0;

}

Объяснение:

Это конечно немного не честно, но у меня не получилось и я посчитал вручную. За такие задачи нужно больше чем )

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота