В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kkkkk24
kkkkk24
21.12.2020 08:54 •  Информатика

8 КЛАСС, НА ПИТОНЕ Напишите программу, которая получает с клавиатуры натуральное число и находит

наименьшую цифру в его десятичной записи.

Показать ответ
Ответ:
ArtemikLis
ArtemikLis
06.01.2021 16:19

Объяснение:

1) вводим с клавиатуры х, затем у. Вычисляем значение данного выражения в f. Выводим результат на экран:

x=int(input('x='))

y=int(input('y='))

f=not(x*y<0) and y>x

print(f)

2) Выводим на экран заголовки столбцов. Затем перебираем в циклах всевозможные значения х, у и z. Выводим их значения и значение логического выражения. На экране получим таблицу.

print('x','y','z', 'F')

for x in range(2):

   for y in range(2):

           for z in range(2):

               print(x,y,z, x and not(not(y) or z) or y)

3) Ничего не придумал, кроме простого перебора всех вариантов:

(x and not(y) and not(z)) or (not(x) and y and not(z)) or (not(x) and not(y) and z)

0,0(0 оценок)
Ответ:
yuniman
yuniman
28.11.2020 19:57

ответ: Задание 1

#include <iostream>

#include <cmath>

double getArea(double side)

{

double S = pow(side, 2) * sqrt(3) / 4;

return S;

}

double getHeight(double side)

{

double H = sqrt(pow(side, 2) - pow(side, 2) / 4);

return H;

}

double getInR(double side)

{

double R = side / sqrt(12);

return R;

}

double getOutR(double side)

{

double R = side / sqrt(3);

return R;

}

int main()  

{

double sideA = 3.5; // длина одной из сторон треугольника, произвольное число;

double area = getArea(sideA);

double height = getHeight(sideA);

double R1 = getInR(sideA);

double R2 = getOutR(sideA);

std::cout << "S = " << area << '\n' << "H = " << height << '\n' << "R1 = " << R1 << '\n' << "R2 = " << R2;

return 0;

}

Задание 4:

#include <iostream>

double Pow(double num, int power)

{

double n = num;

for (int i = 1; i < power; i++)

 num *= n;

return num;

}

int main()  

{

double a = Pow(2, 5); // 2^5=32  

std::cout << a;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота