В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

№9. Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
Входные данные
Входная строка содержит два целых числа.
Выходные данные
Программа должна вывести произведение введённых чисел

Показать ответ
Ответ:
255615
255615
15.08.2021 18:20

1 Вариант:

numbers=list(map(int,input().split()))

if numbers[0] == 0 or numbers[1] == 0:

   print(0)

else:

   print(numbers[0]/(1/numbers[1]))

2 Вариант:

numbers=list(map(int,input().split()))

summ=0

if numbers[1]<0 and numbers[0]<0:

   for i in range(-numbers[0]):

       summ+=-numbers[1]

elif numbers[1]<0:

   for i in range(numbers[0]):

       summ+=numbers[1]

else:

   for i in range(numbers[1]):

       summ+=numbers[0]

print(summ)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота