В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
avrorasergeev
avrorasergeev
23.11.2020 08:53 •  Информатика

9класс ! напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — при знак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести два числа: длину последовательности и сумму чётных чисел.

Показать ответ
Ответ:
marfushakor2006
marfushakor2006
21.08.2020 01:45
Var a,n,s:integer;
begin
n:=0; s:=0;
readln(a);
while a<>0 do
 begin
 n:=n+1;
 if a mod 2=0 then s:=s+a;
 readln(a);
 end;
writeln('n = ',n,'  s = ',s);
end.

Пример:
5
2
8
7
3
0
n = 5 s = 10
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота