В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

«A»: Напишите программу, которая получает два целых числа A и B (0 < A < B) и выводит квадраты всех натуральных чисел в интервале от A до B.

Пример:

Введите два целых числа:

10 12

10*10=100

11*11=121

12*12=144

на языке С++

Показать ответ
Ответ:
sofiapel68p08lqa
sofiapel68p08lqa
05.09.2021 02:29
Amicosinglun.exe - это исполняемый файл (программа) для windows. расширение имени файла  .exe  - это аббревиатура от . слова  executable  — исполнимый. необходимо запускать исполняемые файлы от проверенных производителей программ, потому что исполняемые файлы могут потенциально изменить настройки компьютера или нанести вред вашему компьютеру. бесплатный форум с информацией о файлах может вам разобраться является ли amicosinglun.exe вирусом, трояном, программой-шпионом, рекламой, которую вы можете удалить, или файл принадлежит системе windows или приложению, которому можно доверять. по поводу автозагрузки: попробуй установить программу avast cleanup, она умеет убирать файлы автозагрузки
0,0(0 оценок)
Ответ:
MorohaHaimura
MorohaHaimura
30.03.2021 18:28

Например, в массиве [10, -3, -5, 2, 5] минимальным по модулю элементом является число 2. Его номер 4 (в языках, в которых индексация массивов начинается с нуля, его индекс будет равен 3).

Если стоит задача найти минимальный (или максимальный) элемент по модулю, то значит при поиске нужно сравнивать не сами элементы массива, а их абсолютные значения (модули). Большинство языков программирования имеют встроенную функцию (например, abs()), которая возвращают модуль числа.

Поскольку требуется найти номер минимального по модулю элемента, а не сам элемент (его значение), то при поиске необходимо сохранять индекс найденного на данный момент элемента.

Алгоритм поиска индекса минимального по модулю элемента массива следующий:

Вводим переменную (например, num) и присваиваем ей индекс первого элемента массива (0 или 1 в зависимости от особенностей языка программирования). Тем самым предполагаем, что первый элемент массива и является минимальным по модулю.

Начинаем в цикле перебор массива со второго элемента и до конца. При этом в теле цикла в заголовке условного оператора (if) сравниваем модуль текущего элемента с модулем элемента, чей индекс хранится в переменной num.

Если абсолютное значение текущего элемента массива меньше, чем элемента с индексом num, то в теле условного оператора присваиваем num индекс текущего элемента.

После того, как цикл закончит свою работу, num будет содержать индекс минимального по модулю элемента. Выводим его на экран как есть или увеличиваем на единицу (номер элемента равен индексу при индексации массива с единицы, и на 1 больше индекса при индексации с нуля).

Данное решение задачи не совсем верное, так как находит только первый минимальный элемент. Однако в массиве их может быть несколько (равных между собой или равных между собой только по модулю). Например, в массе [1, 12, 4, 1, 5, 8, 3] минимальных два элемента: первый и четвертый.

Если стоит задача найти номера всех минимальных по модулю элементов, то алгоритм решения задачи будет иным:

Сначала ищется и сохраняется в переменной абсолютное значение минимального по модулю элемента (именно значение, а не индекс).

В следующем цикле каждый элемент (его модуль) сравнивается с ранее найденным минимальным и при совпадении номер текущего элемента выводится на экран.

Ниже в примерах решения задачи на языках программирования реализован первый упрощенный алгоритм (находится только первый минимальный по модулю элемент). Здесь приведем вариант решение задачи по второму алгоритму на языке Pascal:

const N = 20;

var

   arr: array[1..N] of integer;

   i: byte;

   min: integer;

begin

   randomize;

   for i:=1 to N do begin

       arr[i] := random(30)-15;

       write(arr[i]:4);

   end;

   writeln;

 

   min := 100; // хранит минимальное по модулю значение

   for i:=1 to N do

       if abs(arr[i]) < abs(min) then

           min := abs(arr[i]);

   writeln('Минимальное по модулю значение: ', min);

   

   write('Номера элементов: ');

   for i:=1 to N do

       if abs(arr[i]) = min then

           write(i:3);

   writeln;

end.

Пример выполнения кода:

 10  -8  12   3 -14  -3 -14 -15   9  -7   6  -3  -1 -11  -2 -13   1  -7   8 -10

Минимальное по модулю значение: 1

Номера элементов:  13 17

Pascal

(активная вкладка)

Язык Си

Python

КуМир

Basic-256

const N = 10;

var

   arr: array[1..N] of integer;

   i, num: byte;

begin

   randomize;

   for i:=1 to N do begin

       arr[i] := random(100)-50;

       write(arr[i]:4);

   end;

   writeln;

 

   num := 1;

   for i:=2 to N do

       if abs(arr[i]) < abs(arr[num]) then

           num := i;

   writeln(num);    

end.

 36  31 -46 -22 -29 -14  26 -41  15  29

6

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота