В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
bodleva06
bodleva06
11.12.2022 08:18 •  Информатика

А)составьте программу, которая заполняет массив в[1..11] случайными целыми числами в диапазоне от -5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5,а остальные увеличивая в 5 раз. б)составьте программу, которая заполняет массив в[1..12] случайными целыми числами в диапазоне от 1 до 20 и определяет есть ли в массиве нечетные числа и выводит их на экран. в)заполните массив 8 произвольными целыми числами, введя их с клавиатуры и найдите среди них сумму и произведение положительных.

Показать ответ
Ответ:
degtarrusa74
degtarrusa74
04.08.2020 07:23
Задача а
program a;var   i:integer;  a:array[-5..11] of integer; begin  randomize;  for i:=1 to 11 do begin    a[i]:=random(10)-5;    if a[i] mod 5 = 0 then a[i]:=5 else a[i]:=a[i]*5;    write (a[i],' ');    end;end.Задача б
program b;var   i:integer;  a:array[1..12] of integer; begin  randomize;  for i:=1 to 12 do begin    a[i]:=random(20);    if a[i] mod 2 = 1 then write (a[i],' ');    end;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота