Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
TMTkid
15.11.2020 12:14 •
Информатика
Ая опять к вам с по информатике на pascalabc.net в синтаксисе pascal abc. дано натуральное число n. вычислить n! (факториал числа n вычисляется по формуле 1*2*3*…*n, например, факториал числа 5 равен 1*2*3*4*5=120).
Показать ответ
Ответ:
vedmochkasalyt
06.10.2020 09:34
Var
i,n:integer;
p:real;
begin
Write('n='); Read(n);
p:=1;
for i:=1 to n do p:=p*i;
Writeln(n,'!=',p)
end.
Пример
n=12
12!=479001600
0,0
(0 оценок)
Популярные вопросы: Информатика
ЕВБ
11.03.2022 16:22
1. Напиши названня антивирусных программ. 2 вариант...
Maria2604love
28.02.2020 12:57
ХЕЛП Проанализируй и выбери верный ответ. PROGRAM norm; VAR A:INTEGER; B: REAL; C: CHAR; PROCEDURE D (P1: REAL; P2: CHAR); BEGIN (*Начало работы процедуры *) END; (*Конец процедуры*)...
НикаиВикаСестры
28.02.2020 12:57
Среди приведённых ниже трёх чисел записанных в десятичной системе счисления найдите число сумма цифр которого в шестнадцатеричной записи наименьшая. В ответе запишите сумму цифр...
dzyadukh1
04.12.2020 05:05
Табло из лампочек(4 устойчивых состояния) сколько лампочек необходимо чтобы передать 11 сигналов? 100 сигналов?...
MaFizLike
29.07.2020 19:29
Дан одномерный массив из 30 цельных чисел составте програму для вычисления количества чётных элементов массиа...
yanastepina83
23.10.2020 15:22
Как выделить предложения с сочетанием клавиш....
Smillekate
16.12.2022 15:19
ответьте на вопросы ! 1) с войсками какого хана сражался князь дмитрий? 2)кем был богатырь пересвет? 3)на берегах какой реки состоялась куликовская битва? 4)как звали татарского...
Dima98891
16.12.2022 15:19
20 сочинение на тему: василий каширин из рассказа детство характеристика и всякое такое...
alineeeeeel
16.12.2022 15:19
Как правильно не горю или гору желанием...
арина1253
19.02.2023 15:34
Выполните действия 1)-14,3 * 0,6 + 5,7 * (-1,4); 2) (3,4 - 5)*(-4,12 + 4,04); 3) 5/9 * (-3 5/6) - (-3 5/7) * 3/52; 4) (2 1/3 - 3 1/4)*(2 3/4 - 9,95)....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
i,n:integer;
p:real;
begin
Write('n='); Read(n);
p:=1;
for i:=1 to n do p:=p*i;
Writeln(n,'!=',p)
end.
Пример
n=12
12!=479001600