В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
соня3161
соня3161
02.01.2023 07:29 •  Информатика

Без повторений
С заданного массива целых чисел нужно удалить все дублирования элементов. То есть из нескольких одинаковых элементов в массиве остается только элемент с наименьшим индексом.

Входные данные
В первой строке записано число N. В следующей строке записано N целых чисел. Все числа по модулю не превышают 100.

Выходные данные
Вывести элементы массива без повторений в одной строке через пробел, не меняя первоначальный порядок.

Входные данные #1
7
0 1 -2 1 0 0 3
Выходные данные #1
0 1 -2 3
На С++

Показать ответ
Ответ:
ushanoval
ushanoval
13.10.2020 22:10

#include <iostream>

using namespace std;

int main()

{

int i,j,N;

cin >> N;

int* A = new int[N];

for (i = 0; i < N; i++) cin >> A[i];

for (i = 0; i < N; i++)

{

 for (j = 0; j < i; j++)

  if (A[i] == A[j]) break;

 if (i==j) cout << A[i] << " ";

}

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота