В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
y2334455
y2334455
21.04.2022 07:21 •  Информатика

Билет №31. НА ЯЗЫКЕ PYTHON, КТО СКОЛЬКО МОЖЕТ

1. Определить и вывести на экран цифры целого числа n. Например: 568(первая цифра справа равна 8,вторая цифра равна 6..)Решить задачу необходимо через цикл While и построить блок схему.
2. Написать программу определения максимального числа последовательности положительных чисел. Решить задачу необходимо через «Любой Цикл» и построить блок схему.
3. У гусей и кроликов вместе 64 лапы. Сколько может быть кроликов и сколько гусей (указать все возможные сочетания) Решить задачу необходимо через For и построить блок схему.
4. Посчитать все отрицательные числа, положительные возвести в 5 степень и вывести на экран. (Числа задаются датчиком случайных чисел в диапазоне от -43 до 15 ). Решить задачу необходимо через if и построить блок схему.
5. По номеру дня вычислить числа и месяца не високосного года. Решить задачу необходимо через Оператор выбора и построить блок схему.

Показать ответ
Ответ:
asadbek7703
asadbek7703
30.12.2021 19:11
1.Компьютер - незаменимая вещь в жизни студента. 
2.Мама обрадовала Петю: он совсем не ожидал получить компьютер на день рождения.
3. Учительница сказала, что сегодня мы будем работать на компьютере. 
4. Паскаль- самый сложный язык в программировании на компьютере. 
5. Вова обожал играть в видеоигры на компьютере. 
6. "Ребята, сегодня наш класс пойдёт смотреть в технический музей на первые компьютеры"- сказала учительница.
7. Бабушка удивилась, что Катенька так быстро печатает на компьютере. 
8. Настя была опечалена: из-за сломанного usb-порта компьютер не воспринимал съемный носитель. 
9. Первые компьютеры были очень большими. 
10. Милана очень хотела новый компьютер, но папа посчитал нужным подарить ей книги. 
0,0(0 оценок)
Ответ:
NadyaSmirnovaa
NadyaSmirnovaa
21.08.2022 15:29
Const n=15; 
var a:array[1..n] of integer;
i,s:integer; sr:real;
begin
Randomize;
writeln('Массив:');
for i:=1 to n do
 begin
 a[i]:=random(21);
 write(a[i]:3);
 end;
writeln;
s:=0;
for i:=1 to n do s:=s+a[i];
sr:=s/n;
writeln('Среднее арифметическое = ',sr:6:2);
writeln('Номера элементов, больших среднего арифметического:');
for i:=1 to n do
 if a[i]>sr then write(i:3);
writeln;
end.

Пример:
Массив:
  9 19 14 8 7 10 5 10 6 14 15 2 11 17 13
Среднее арифметическое = 10.67
Номера элементов, больших среднего арифметического:
  2 3 10 11 13 14 15
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота