Boolean составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае: 1) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр; 2) с�мма цифр данного трехзначного числа n является четным числом; 3) точка с координатами (х, у) принадлежит части плоскости, лежащей между прямыми x = m, x = n (m < n); 4) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа; 5) целое число n является четным двузначным числом; 6) треугольник со сторонами а, b, c является равносторонним; 7) треугольник со сторонами а, b, c является равнобедренным; 8) среди чисел a, b, c есть хотя бы одна пара взаимно противоположных чисел; 9) числа c и b выражают длины катетов одного прямоугольного треугольника, а c и d – другого. эти треугольники являются подобными; 10) даны три стороны одного и три стороны другого треугольника. эти треугольники равновеликие, т.е. имеют равные площади; 11) данная тройка натуральных чисел a, b, c является тройкой пифагора, т.е. c2 = a2 + b2; 12) все цифры данного четырехзначного числа n различны; 13) данные числа x, y являются координатами точки, лежащей в первой координатной четверти; 14) (х1, у1) и (х2, у2) – координаты левой верхней и правой нижней вершин прямоугольника; точка а(х, у) лежит внутри этого прямоугольника или на одной из его сторон; 15) число с является средним арифметическим чисел a и b; 16) натуральное число n является точным квадратом; 17) цифры данного четырехзначного числа n образуют строго возрастающую последовательность; 18) цифры данного трехзначного числа n являются членами арифметической прогрессии; 19) цифры данного трехзначного числа n являются членами прогрессии; 20) данные числа c и d являются соответственно квадратом и кубом числа а; 21) цифра м входит в десятичную запись четырехзначного числа n; 22) данное четырехзначное число читается одинаково слева направо и справа налево; 23) сумма двух натуральных чисел кратна 2; 24) произведение натуральных чисел a и b кратно числу с; 25) сумма двух действительных чисел a и b является целым числом, т.е. дробная часть суммы равна нулю; 26) данное натуральное число а кратно числу b, но не кратно числу с.
n,t,s,d,e:integer;
begin
writeln('');
repeat
writeln('Введите сумму в рублях<=1000');
readln(n);
until (n>0) and (n<=1000);
t:=n div 1000;
n:=n-t*1000;
s:=n div 100;
n:=n-s*100;
d:=n div 10;
if d<>1 then
begin
n:=n-d*10;
e:=n;
end;
case t of
1:write('тысяча ');
end;
if s>=0 then
case s of
1:write('сто ');
2:write('двести ');
3:write('триста ');
4:write('четыресто ');
5:write('пятьсот ');
6:write('шестьсот ');
7:write('семьсот ');
8:write('восемьсот ');
9:write('девятьсот ');
end;
if d>=0 then
case d of
1:
case n of
10: write('десять ');
11: write('одиннадцать ');
12: write('двенадцать ');
13: write('тринадцать ');
14: write('четырнадцать ');
15: write('пятнадцать ');
16: write('шестнадцать ');
17: write('семнадцать ');
18: write('восемнадцать ');
19: write('девятнадцать ');
end;
2:write('двадцать ');
3:write('тридцать ');
4:write('сорок ');
5:write('пятьдесят ');
6:write('шестьдесят ');
7:write('семьдесят ');
8:write('восемьдесят ');
9:write('девяносто ');
end;
if e>=0 then
case e of
1:write('один ');
2:write('два ');
3:write('три ');
4:write('четыре ');
5:write('пять ');
6:write('шесть ');
7:write('семь ');
8:write('восемь ');
9:write('девять ');
end;
if (e=1) then write('рубль ')
else if (e=0)or(e>4) then write('рублей ')
else write('рубля ');
end.