В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

C/c++ составить программу возведения натурального числа n в квадрат, учитывая такую закономерность: 1 ^ 2 = 1, 2 ^ 2 = 1 + 3, 3 ^ 2 = 1 + 3 + 5, 4 ^ 2 = 1 + 3 + 5 + 7, п ^ 2 = 1 + 3 + 5 + 7 + 9 + + 2n-1. не использовать операцию умножения!

Показать ответ
Ответ:
liza2002623
liza2002623
09.10.2020 01:51

#include <iostream>


using namespace std;


int main() {

long int i, number, square = 0;


jump:

cout << "Input a natural number: ";

cin >> number;

if (number <= 0) {

             cout << "Input error! Try again"<< endl;

             goto jump;

}


for(i = 1; i <= number; i++)

              square += i + i - 1;


cout << "The square of number " << number << " is " << square << endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота