Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
uhjvjvjkybz
12.07.2021 16:41 •
Информатика
C++ имеется массив a[0],a[2],-1]. найти сумму квадратов элементов массива. предполагается, что n и a[0],a[2],-1] вводятся с пульта. сумму распечатать.
Показать ответ
Ответ:
topovychuvak
31.08.2020 17:35
//Dev-C++ 5.11
#include <iostream>
using namespace std;
int main(void)
{int *a,n;
long long int sum=0;
cin>>n;
a=new int[n];
for(int i=0;i<n;i++)
{cin>>a[i];
sum+=a[i]*a[i];}
cout<<sum;
return 0;}
Пример ввода:
3
1
2
3
Пример ввода:
14
0,0
(0 оценок)
Популярные вопросы: Информатика
natalyakazarya
17.01.2022 11:17
Файл прикреплён выше смотри заполните таблицу...
Anastasia191327
15.04.2023 23:16
Нужно написать программу на Питоне!Гвоздей в каждой подкове шесть. За первый гвоздь дай мне всего 1/4 копейки, за второй - 1/2 копейки, за третий - 1 копейку и т.д. . Покупатель,...
JakeNJacks
02.07.2022 11:49
Задание 2. У Алины день рождения. Повар должен сделать сюрприз девочке. Для этого вам нужно написать команды по алгоритму. При стрелки соедините порядковый номер команды с...
Tima411
06.09.2022 21:32
Имя обьекта дерево свойства обьекта?...
dashakostyk
27.12.2021 06:48
Весть елочка.зеленая с шарами и звездой.; какие инструменты графического редактора paint не были использованны для рисования елочки. 1буфер обмена 2кисти 3фигуры...
Kat11166
11.12.2021 02:21
1. колебательный контур состоит из конденсатора емкостью 0,1 мкф и катушки индуктивностью 0,001 гн. выберите верноевысказыванне и отметьте знаком х в соответствующей клетке.-период...
дэдшотер
23.04.2020 23:07
Как изменится скорость прямой реакции в системе 2so2(г.)+o2(г.)= 2so3( если при постоянной температуре увеличиться давление в 2,5 раза? и в какую сторону сместится равновесие?...
krichilskaatтанюшка
03.12.2020 21:33
Сделайте разбор слов : разговаривает² , выглядывает²....
ankavasilenko2
24.08.2021 07:42
Какое из ряда существительных склоняется не совсем так,как остальные. а.бедро б.ведро в.весело г.крыло д.ребро умоляю...
klimkravcnko
09.05.2020 00:34
Придумать 3 предложения из 3 слов,придумать свой шифр,записать зашифрованное предложение,указав правила шифровки...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <iostream>
using namespace std;
int main(void)
{int *a,n;
long long int sum=0;
cin>>n;
a=new int[n];
for(int i=0;i<n;i++)
{cin>>a[i];
sum+=a[i]*a[i];}
cout<<sum;
return 0;}
Пример ввода:
3
1
2
3
Пример ввода:
14