В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
VaNyOkToP
VaNyOkToP
18.06.2021 22:37 •  Информатика

C# Написать программу, содержащую класс Студент со следующими полями: Фамилия, Имя, Возраст, Группа, Отметки (использовать целочисленный массив) и методами: вывода информации о студенте и расчет среднего значения Успеваемости

Показать ответ
Ответ:
irinakarimova2
irinakarimova2
15.10.2020 14:53

using System;

using System.Collections;

using System.Collections.Generic;

using System.Linq;

namespace CSLear

{

   partial class Program

   {

       static void Main(string[] args)

       {

           Student Лёха = new Student("Свотин", "Алексей", 21, "ПИ 2-3", new int[5] { 4, 5, 3, 5, 3, });

           Лёха.GetInfo();

           Console.WriteLine($"Отдельно выведенные оценки Лёхи: {Лёха.AverageMark}");

           Console.ReadKey();

       }

   }

   class Student

   {

       public string Surname { get; set; }

       public string Name { get; set; }

       public int Age { get; set; }

       public string Group { get; set; }

       public int[] Marks { get; set; }

       public double AverageMark => Marks.Average();

       public Student(string Surname, string Name, int Age, string Group, int[] MarkList)

       {

           this.Surname = Surname;

           this.Name = Name;

           this.Age = Age;

           this.Group = Group;

           Marks = MarkList;

       }

       public void GetInfo()

       {

           Console.WriteLine($"Студент: {Surname} {Name}\nГруппа: {Group}\nСредний : {AverageMark}");

       }

   }

}

Объяснение:

Да, в VS 2019 можно использовать кириллицу для наименования переменных.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота