В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
3462686
3462686
01.05.2023 08:01 •  Информатика

C#
Написать программу, в которой вводятся с клавиатуры предложения, и выводит на экран только цитаты, то есть предложения, заключенные в кавычки.

Показать ответ
Ответ:
киреева2
киреева2
15.10.2020 12:45

using System;

using System.Text.RegularExpressions;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           string s;

           Console.WriteLine("Введите текст:");

           s = Console.ReadLine().Replace('\"','\'');

           Regex r = new Regex(@"'[^']+'");

           foreach (Match m in r.Matches(s))

               Console.WriteLine(m.Value);

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота