В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
birdibir
birdibir
13.09.2022 22:05 •  Информатика

C++ Напишите программу, которая находит все цифры, которых нет в переданной ей строке.

Входные данные
На вход программа подаётся символьная строка.

Выходные данные
Программа должна вывести в одной строке все цифры, которые не встречаются в исходной строке, в порядке убывания. Если таких цифр нет, нужно вывести слово 'NO'.

Показать ответ
Ответ:
anara01051979
anara01051979
28.09.2021 10:48
Алгоритм
1) a x a = a² ⇒ b;    b x a = a³ ⇒ результат
2) a x a = a² ⇒ b;    b x b = a⁴ ⇒ c;   c x c = a⁸ ⇒ c;   c x b = a¹⁰ ⇒ результат

Программа на языке PascalABC.Net
var
  a,b,c,y:real;
begin
  Write('Введите число: '); Read(a);
  b:=a*a; y:=b*a; Writeln('Третья степень числа равна ',y);
  c:=b*b; c:=c*c; y:=b*c;
  Writeln('Десятая степень числа равна ',y)
end.

Тестовые решения:
Введите число: 2
Третья степень числа равна 8
Десятая степень числа равна 1024

Введите число: -13.594
Третья степень числа равна -2512.128188584
Десятая степень числа равна 215512594781.574
0,0(0 оценок)
Ответ:
Маруся200117
Маруся200117
03.10.2022 05:34

Программа:

s = int(input('Итак, каков наш капитал?\nКапитал: '))

print('Давайте-ка в нашу пиццерию добавим разные блюда!')

a, b = [], []

for i in range(int(input('Сколько пицц будет в меню?\nКол-во: '))):

   a += [input('Введите название пиццы: ')]

   b += [int(input('Введите цену: '))]

print('Прекрасно! Вот списочек:', *a)

print('Начинаем игру!')

def is_true(num):

   if num in ''.join(a):

       return num

   else:

       print('Такой пиццы нет, может возьмёте что-то из списка?', *a)

       return is_true(input())

ok = True

while ok:

   if s:

       print('Какую пиццу вы хотите? ')

       q = is_true(input())

   else:

       print('Денюжка кончилась за игру!')

       break

   for i in range(len(a)):

       if q == a[i]:

           m = 0

           for j in b:

               m = max(s - j, m)

           if s - b[i] > 0 or s - b[i] == 0:

               print('Заказ принят!')

               print('Готовим..')

               print('С вас', b[i])

               s -= b[i]

           elif s - b[i] < 0 and (m or m == 0):

               print('Извините, выбирите что-то другое, наш бюджет:', s)

           else:

               print('Денюжка кончилась за игру!')

               ok = False

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота