В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Love25252525
Love25252525
18.10.2022 01:16 •  Информатика

C++
Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке.
Входные данные:
Входная строка содержит три целых числа, разделённых пробелами.
Выходные данные:
Программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные.

Показать ответ
Ответ:
lizalist0506
lizalist0506
12.10.2020 23:15

#include <iostream>

int main()

{

int a, b, c;

std::cout << "Enter 3 Numbers: ";

std::cin >> a >> b >> c;

std::cout << "\n";

if (a==b && b==c)

   std::cout << "All numbers are the same";

if ((a==b && a!=c) || (a==c && a!=b) || (b==c &&b!=a))

   std::cout << "Two numbers are similar";

if ((a!=b) && (a!=c) && (b!=c))

   std::cout << 0;

return 0;

}

Объяснение:


C++ Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цеп
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота