В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Tapoocek
Tapoocek
22.05.2021 07:04 •  Информатика

C++ Напишите программу, которая считывает данные пользователя:
-Имя
-Nazwisko
-высота
-программа

ponien вычислить ИМТ и сообщение wyspisac:
16 - 16,99 - голод
17 - 18,49 - недостаточный вес
18,5 - 24,99 -значение введите допустимое значение
25-29,99 -надвага
30 - 34,99 - I ожирение
35 - 39,99 - II ожирение
старше 40 лет - крайнее ожирение
* Индекс массы тела (ИМТ) рассчитывается очень просто. Разделите свой вес в килограммах на свой рост в метрах в квадрате.
Измените так, чтобы все списки ИМТ с именем и фамилией, дополненными датой, указанной пользователем, сохранялись в файле. Файл должен содержать все записи, которые когда-либо были введены.

Показать ответ
Ответ:
TheSniper
TheSniper
30.01.2021 08:38
//Pascal ABC.NET v3.0 сборка 1111

var
 i,a,b:integer;
 ar:array[1..10] of integer;

 procedure oddDec(var a,b:integer);  //подпрограмме переданы аргументы a и b
//процедура для вычитания в нечётном элементе
begin;
a:=a-b;
end;

procedure NotoddInc(var a,b:integer); //подпрограмме переданы аргументы a и b
//процедура для сложения в чётном элементе
begin;
a:=a+b;
end;

begin
randomize;
readln(a); //ввод a
readln(b); //ввод b
writeln('Array:');
for i:=1 to 10 do //весь массив
 begin;
  ar[i]:=random(-20,80); //случайные числа от -20 до 80 включительно
  write(ar[i]:4); //вывод
  if odd(i) then oddDec(ar[i],b) else NotoddInc(ar[i],a);
  {если нечётное, то первая процедура, иначе вторая. Обращаю внимания на то, что элементы меняются сразу после вывода}
 end;
writeln;
writeln('Final array:'); //вывод получившегося массива
for i:=1 to 10 do
write(ar[i]:4);
end.

Пример ввода:
20
10
Пример вывода:
Array:
  10  16   0  60  23   4  22 -20   4  55
Final array:
   0  36 -10  80  13  24  12   0  -6  75  
0,0(0 оценок)
Ответ:
Evgen2100zzz
Evgen2100zzz
19.01.2020 02:09

Лента в Microsoft Word позволяет максимально быстро получить доступ к наиболее часто используемым командам. Лента содержит огромное количество команд, которые разбиты по смысловым группам. В этом уроке Вы узнаете, из каких вкладок состоит Лента, а также научитесь скрывать ее, чтобы увеличить рабочую область Word на экране монитора.

Если Вы ранее пользовались Word 2010 или 2007, тогда Word 2013 покажется Вам знакомым. В нем используются все те же Лента и Панель быстрого доступа, где можно найти команды для наиболее часто используемых задач, а также представление Backstage.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота