В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Tusya007
Tusya007
26.09.2021 13:01 •  Информатика

C++ напишите программу, которая в последовательности целых чисел определяет разность максимального и минимального чисел. программа получает на входе целее числа, количество введённых чисел неизвестно, последовательность чисел заканчивается число 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30000. программа должна вывести одно число: разность максимального и минимального чисел.

Показать ответ
Ответ:
genatbukin
genatbukin
02.10.2020 19:45
#include <iostream>
#include <vector>
using namespace std;
int main()
{
vector <int> v (1000);
int max = -30000;
int min = 30000;
for (int i = 0; i <1000; ++i) {
cin >> v[i];
if (v[i] == 0) break;
if (v[i] >= max) max = v[i];
if (v[i] <= min) min = v[i];
}
cout << max -min <<endl;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота