C++
Напишите программу, которая заменяет в символьной строке все буквы a на буквы b (латинские, строчные).
Входные данные
Входная строка содержит символы латинского алфавита, как строчные, так и заглавные.
Выходные данные
Программа должна заменить во всей строке строчные буквы a на буквы b и вывести в первой строке получившуюся символьную строку, а во второй – количество выполненных замен.
Примеры
входные данные
aabbccabadef
выходные данные
ccbbbdef
4
procedure RectangleSquare;
var
a,b:double;
begin
Write('Введите через пробел длины сторон прямоугольника: '); Read(a,b);
Writeln('Площадь прямоугоьника равна ',a*b)
end;
var
i:byte;
begin
for i:=1 to 3 do RectangleSquare
end.
Тестовое решение:
Введите через пробел длины сторон прямоугольника: 3 7
Площадь прямоугоьника равна 21
Введите через пробел длины сторон прямоугольника: 12.4 15.8
Площадь прямоугоьника равна 195.92
Введите через пробел длины сторон прямоугольника: 14 12.5
Площадь прямоугоьника равна 175
Оптический телеграф Оптический телеграф В 1792 году во Франции Клод Шапп создал систему передачи визуальной информации, которая получила название «Оптический телеграф» . В простейшем виде это была цепь типовых строений, с расположенными на кровле шестами с подвижными поперечинами, которая создавалась в пределах видимости одно от другого. Шесты с подвижными поперечинами — семафоры — управлялись при тросов специальными операторами изнутри строений. Шапп создал специальную таблицу кодов, где каждой букве алфавита соответствовала определенная фигура, образуемая семафором, в зависимости от положений поперечных брусьев относительно опорного шеста. Система Шаппа позволяла передавать сообщения на скорости два слова в минуту и быстро распространилась в Европе. В Швеции цепь станций оптического телеграфа действовала до 1880 года