В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Polklop
Polklop
08.02.2021 09:14 •  Информатика

C++ напишите программу, которая запрашивает пять целых чисел и выводит в первой строке сумму первых двух чисел, во второй строке -- сумму первых трёх чисел, в третьей строке -- сумму первых четырёх чисел, в четвёртой строке -- сумму всех пяти чисел. заранее !

Показать ответ
Ответ:
ученикпро1
ученикпро1
09.10.2020 00:59

#include <array>

#include <iostream>

#include <algorithm>

#include <numeric>

#include <iterator>

int main()

{

   std::array<int, 5> arr;

   std::generate(arr.begin(), arr.end(), []()

   {

       return 1 + std::rand() % 100;

   });

   std::copy(arr.begin(), arr.end(),

       std::ostream_iterator<int>(std::cout, " "));


   std::cout << std::endl << std::accumulate(arr.begin(), arr.end()-3, 0) << std::endl;

   std::cout << std::accumulate(arr.begin(), arr.end()-2, 0) << std::endl;

   std::cout << std::accumulate(arr.begin(), arr.end()-1, 0) << std::endl;

   std::cout << std::accumulate(arr.begin(), arr.end(), 0) << std::endl;

}


C++ напишите программу, которая запрашивает пять целых чисел и выводит в первой строке сумму первых
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота