В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
LyVlAr
LyVlAr
20.09.2020 23:14 •  Информатика

C++ нужно написать программу которая бы из целого числа делала сумму чисел и произведение (в двух разных строчках)

Показать ответ
Ответ:
titova2017
titova2017
04.12.2021 18:50

#include <iostream>

using namespace std;

int main(){

   string n;

   int sum;

   while (true){

       sum=0;

       cout<<"\nEnter integer : ";

       cin>>n;

       for (int i=0; i<n.size(); i++)

           sum+=n[i]-'0';

       cout<<"Sum of digits : "<<sum<<endl;

       system("pause");

   }

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота