В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
roma280274
roma280274
26.08.2020 21:57 •  Информатика

C++
составьте программу перевода старинных мер длины, торгового и аптекарского веса(счетчик цикла от 1 до 10)
* саженей в метры(1 сажень равна 2,1366 м)
* из дюймов в сантиметры(1 дюйм равен 2,5 см)
* футов в метры(1 фут равен 0,3048 м)
* драхм в граммы(1 драхма равна 3,7325 г)
* унций в граммы(1 унция равна 29,86 г)
* фунтов в килограммы(1 фунт равен 0,40951 кг)
* аршинов в метры(1 аршин равен 0,7112 м)
* золотников в граммы(1 золотник равен 4,2657 г)
* дюймов в миллиметры(1 дюйм равен 25,3995 мм)

Показать ответ
Ответ:
маришка213
маришка213
07.12.2020 01:58
Var M, Day : integer; Sm, S : real;
begin
writeln('Вычисление стоимости телефонного разговора');
writeln('Введите исходные данные');
writeln('Стоимость минуты разговора, руб. ');
readln(Sm);
writeln('Длительность разговора (целое количество минут) ');
readln(M);
writeln('День недели (1-понедельник, ... 7-воскресенье) ');
readln(Day);
S:=Sm*M;
if (Day=6)or(Day=7)
 then writeln('Стоимость разговора с учетом скидки = ',S*0.8,' руб')
 else writeln('Стоимость разговора = ',S,' руб');
end.

Пример:
Вычисление стоимости телефонного разговора
Введите исходные данные
Стоимость минуты разговора, руб. 
1
Длительность разговора (целое количество минут) 
6
День недели (1-понедельник, ... 7-воскресенье) 
7
Стоимость разговора с учетом скидки = 4.8 руб
0,0(0 оценок)
Ответ:
sevamalashkin
sevamalashkin
07.12.2020 01:58
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Вычисление стоимости телефонного разговора');
  Writeln('Введите исходные данные');
  var Sm:=ReadReal('Стоимость минуты разговора, руб.');
  var M:=ReadInteger('Длительность разговора (целое количество минут)');
  var Day:=ReadInteger('День недели (1-понедельник, ... 7-воскресенье)');
  var S:=Sm*M*(Day in [1..5]?1.0:0.8);
  Writeln('Стоимость разговора, руб ',s:0:2)
end.

Пример
Вычисление стоимости телефонного разговора
Введите исходные данные
Стоимость минуты разговора, руб. 1
Длительность разговора (целое количество минут) 6
День недели (1-понедельник, ... 7-воскресенье) 7
Стоимость разговора, руб 4.80
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота