В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
RomanPopov2005
RomanPopov2005
17.07.2022 01:09 •  Информатика

C# составьте программу вывода на экран первых n чисел, делящихся на 4 или 5 (используйте break).

Показать ответ
Ответ:
dekok584p08crj
dekok584p08crj
06.12.2021 15:07

Відповідь:

Міркуючи логічно, ви можете включити одну лампу, другу вимкнути, а ось що робити з третьої - незрозуміло. Станів лампи всього два: або «включена», або «вимкнена». Найпопулярніший б вирішення полягає в тому, щоб в якості третьої стану додати поділ ламп на «теплі» і «холодні». Потрібно почекати якийсь час, щоб лампи охололи на випадок, якщо вони недавно включалися. Потім включити одну для нагрівання. Вимкнути її назад і включити будь-яку іншу. Зайшовши після цього в кімнату одна лампа буде горіти, друга виключена і холодна, третя виключена і гаряча. Інший варіант додати лампам стан «перегоріла», якщо є можливість подати на перемикач більшу напругу, ніж потрібно. Дальше действовать аналогічно попередньої схеми.

Пояснення:

0,0(0 оценок)
Ответ:
NadyaSmirnovaa
NadyaSmirnovaa
21.08.2022 15:29
Const n=15; 
var a:array[1..n] of integer;
i,s:integer; sr:real;
begin
Randomize;
writeln('Массив:');
for i:=1 to n do
 begin
 a[i]:=random(21);
 write(a[i]:3);
 end;
writeln;
s:=0;
for i:=1 to n do s:=s+a[i];
sr:=s/n;
writeln('Среднее арифметическое = ',sr:6:2);
writeln('Номера элементов, больших среднего арифметического:');
for i:=1 to n do
 if a[i]>sr then write(i:3);
writeln;
end.

Пример:
Массив:
  9 19 14 8 7 10 5 10 6 14 15 2 11 17 13
Среднее арифметическое = 10.67
Номера элементов, больших среднего арифметического:
  2 3 10 11 13 14 15
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота