В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

C++, задача с массивом и разрядностью чисел
Вводится последовательность из N положительных целых чисел. Определить
разрядность каждого числа.
Написать программу на с++, желательно только со стандартными библиотеками.
Написать через for, while, do while (разными циклами)

Показать ответ
Ответ:
toniskvortsov1
toniskvortsov1
11.09.2020 19:39

#include <iostream>

#include <cstdlib>

using namespace std;

int main()

{

setlocale(LC_ALL,"russian");

cout << "Введите размер массива: ";

int N;

cin >> N;

N=N--;

unsigned int a[N];

for (int b = 0; b<=N; b++)

{

cout << "Введите число номер " << b << ": ";  

cin >> a[b];

}

for(int i=0; i<=N; i++)

{

if(a[i]<=255)

{

 cout << "Количество разрядов числа " << a[i] << " - 8" << endl;

}

if(a[i]>=256 && a[i]<=65535)

{

 cout << "Количество разрядов числа " << a[i] << " - 16" << endl;

}

if(a[i]>=65536 && a[i]<=4294967295)

{

 cout << "Количество разрядов числа " << a[i] << " - 32" << endl;

}

}

   system("pause");

   return 0;

}

Надеюсь, правильно понял определение разрядов.

Есть пожелания - в комментарии

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота