Цель: закрепить знания по программированию на языке Паскаль (линейный алгоритм, разветвляющийся, цикличный алгоритм).
Составьте программу по образцу на Паскаль и запишите ее для вывода со своими переменными: a=810, g=16.
program lineiny;
Var x,y: integer;
Begin
x : = 432;
y:=21;
y : = x div 100+y;
x : = ( x mod 100 ) * 10;
x : = x + y;
writeln(x);
End.
Составьте программу на нахождение площади круга.
Составьте программу по образцу на Паскаль и запишите ее для s := 0,
цикл k от 3 до 8, s := k + 7, переменные: цел s, k, найти s.
program cikl;
Var s,k: integer;
Begin
s := 0;
for k := 3 to 8 do
s := k + 9;
writeln(s);
End.
Составьте программу на Паскаль на условие по принадлежности точки отрезку АВ.
Составьте программу на Паскаль case of по образцу на числа от 6 до 9:
program vetvlenija;
var NUM :integer;
begin
writeln('Введите число от 0 до 3:');
readln (NUM);
case NUM of
0:writeln ('Нуль');
1:writeln ('Один');
2:writeln ('Два');
3:writeln ('Три')
else writeln ('Такого нет');
end;
end.
Примечание: использование программы PascalABCNET для выполнения номеров разрешается.
Двигаемся в обратном порядке 2324142 (идём с конца) ей противоположные 1323141
2 задание) ответ: 2949;
мы должны получить 11 и 13 причем минимально . можем только так 9+2 и 9+4 . значит 2949
3 задание) ответ: 3;
чтобы добраться до 21 нам нужно выполнить 1 команду 6 раз и 3 раза вторую , нас спрашивают про вторую пишем ответ 3
4 задание) ответ: 1;
нам нужно число которое делится на 5 то есть 4 отпадает , и также нам нужно чтобы модуль разности был не более 2 и во втором и в третьем модуль разности больше 2 , остается 1.
5 задание) ответ: 1112221;
Я всегда начинаю с обратного
57-56-28-14-7-6-5-4 собираем с конца 1112221
Если число 3306(10) в системе исчисления с основанием а заканчивается цифрой 3, то тогда
число 3303 делится на основание системы а.
Отсюда алгоритм поиска. Находим все делители числа 3303.
3303 = 3*1101 = 3*3*367. Число 367 - простое. Поэтому основаниями системы исчисления
могут быть только 3, 9, 367. Основание =3 не подходит, так как по условию число должно заканчиваться на 3 -> основание больше 3. Остаются 9, 367.