В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
vikasibarik
vikasibarik
23.09.2021 21:05 •  Информатика

Через паскаль! тема: «поиск наибольшего или наименьшего элемента массива» написать программу, которая запрашивает у пользователя строку и заменяет в ней все пробелы знаками подчеркивания '_' не использовать: const, count и другие, которые не по теме!

Показать ответ
Ответ:
ekaterinaefimenko16
ekaterinaefimenko16
08.10.2020 14:30
Var i: Integer;
s: String;
begin
writeln('Введите текст');
readln(s);
for i:=1 to Length(s) do
begin
if s[i]=' ' then s[i]:='_';
end;
writeln(s);
end.
0,0(0 оценок)
Ответ:
nastyacrew
nastyacrew
08.10.2020 14:30
Var
    g: string;
    i: byte;
begin
    readln(g);
    i := 1;
    while g[i] = ' ' do delete(g,i,1);
    i := length(g);
    while g[i] = ' ' do begin delete(g,i,1); i := i - 1 end;
    i := 1;
    while i <= length(g) do begin
  if g[i] = ' ' then
   if g[i-1] = '*' then begin
    delete(g,i,1);
    i := i - 1;
   end
   else begin
    delete(g,i,1);
    insert('_',g,i);
   end;
  inc(i);
    end;
    writeln(g);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота