Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
covepoxamu
12.12.2020 06:34 •
Информатика
Чтобы найти наибольший общий делитель постройте программу используя эту формулу : нод(а,b,c)=нод(нод(а, через программу паскаль) program=evklid
Показать ответ
Ответ:
Akri2532
06.07.2020 16:50
Var a,b,c,x :integer;
function NOD(a,b:integer):integer;
begin
while a<>b do
if a>b then
a:=a-b
else b:=b-a;
Result:=a;
end;
begin
write('Введите a,b,c: ');
readln(a,b,c);
x:=NOD(NOD(a,b),c);
writeln('НОД=',x)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ДЕСПАСИТТО58
10.08.2022 01:19
В чем особенности компьютерной программы?...
Minecraftserver34
07.09.2022 12:52
Определите значение переменной «a» после выполнения фрагмента программы:a := 10; b := 10; if a b thenb := b + 12 elsea := a - 7;if a b thena :=a + 12;...
lailasarsenbaev
27.11.2021 00:29
Program a2; var a,b,c,min: real; begin writeln( введите три числа ); readln(a,b,c); min: =a; if b if c writeln( min= ,min) end.как а)а=10,b=5 и с =1 б)а=10,b=5 и с...
umidmadrimow580
27.11.2021 00:29
Вгараже 80 автомобилей сколько бит необходимо для кодирования каждого автомобиля...
raykova568
05.02.2020 12:14
ПИТОН! За спам сразу бан , так что без этого...
nugumanovsalavp092yo
22.02.2023 23:11
Петя нарисовал в графическом редакторе paint восемь кружков три красных и пять синих.Сколько кружков у него получилось после выполнения следующего алгоритма действий?...
polinakarpenko3
02.03.2023 14:04
Python Напишите фрагмент программы, который вычисляет количество ненулевых элементов матрицы в переменной count....
fedorbrednikoff
07.06.2021 16:03
На паскале Для N чисел, заданных случайным образом [-25;20], подсчитать сумму и количество чётных чисел, кратных 3. Значение N ввести с клавиатуры. 1. Построить знаковую...
дариночка064
04.01.2021 11:21
Python! Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером)....
77Stranik77
17.08.2022 21:37
Ребята Умоляю Постройте словесную модель автомобиля...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
function NOD(a,b:integer):integer;
begin
while a<>b do
if a>b then
a:=a-b
else b:=b-a;
Result:=a;
end;
begin
write('Введите a,b,c: ');
readln(a,b,c);
x:=NOD(NOD(a,b),c);
writeln('НОД=',x)
end.