В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Poligrinka
Poligrinka
21.12.2020 04:27 •  Информатика

Чуваки, . не шарю совсем, надо написать программу и лучше с объяснениями. дано натуральное число. верно ли, что в данном числе нет данной цифры а (цифру а вводить с клавиатуры)

Показать ответ
Ответ:
leonik9797
leonik9797
09.08.2020 07:51
Требуемая программа:
var n,a: longint; b: boolean;
begin
readln(n);
readln(a);
b:=false;
while n>0 do
 begin
 if n mod 10 = a then b:=true;
 n:=n div 10;
 end;
if b 
 then writeln('В числе есть введенная цифра')
 else writeln('В числе нет введенной цифры');
end.

Пример:
1236548
2
В числе есть введенная цифра
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота