В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
pavel266
pavel266
23.04.2023 03:48 •  Информатика

Цикл с параметром.pascale.нужно написать программу. определить количество чисел, кратных 5, среди n чисел, заданных случайным образом в диапозоне от -50 до 50.

Показать ответ
Ответ:
vitalicc
vitalicc
01.10.2020 10:00
Const nmax = 30;
var a:array [1..nmax] of integer;
      i,k,n:integer;
begin
  randomize;
  k:=0;
  repeat
    write ('N = ');
    readln (n);
  until n in [1..nmax];
  for i:=1 to n do
    begin
      a[i]:=random(101)-50;
      writeln (a[i]);
      if a[i] mod 5 = 0 then inc(k);
    end;
  writeln ('Kol-vo: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота