Циклы в Python: 7. Проверить является ли введенное число степенью двойки и, если да, то какой.
8. Перед вами на столе две бутылки. Bottle_1 пустая и имеет объем в 500 мл, Bottle_2 объем в Х (вводится пользователем) мл кваса меньший, чем объем Bottle_1, . Не используя операции деления, определите сколько раз можно перелить объем Bottle_2 в Bottle_1
var s:string; m1,m2,m3:integer;
begin
writeln('- Привет! Я компьютер, а как тебя зовут?');
write('- '); readln(s);
writeln('- ',s,', введи свои оценки по 3 предметам');
write('- '); readln(m1,m2,m3);
writeln('- ',s,', твой средний ', (m1+m2+m3)/3);
end.
Пример:
- Привет! Я компьютер, а как тебя зовут?
- Алёна
- Алёна, введи свои оценки по 3 предметам
- 4 4 4
- Алёна, твой средний 4
2.
var a,b:integer;
begin
write('a = '); readln(a);
b:=(a div 100)*100 + (a mod 10)*10 + (a div 10 mod 10);
writeln('b = ',b);
end.
Пример:
a = 123
b = 132
s: string;
a, b: integer;
begin
readln(s);
if s[1] = 'x' then begin
a := StrToInt(s[3]);
b := StrToInt(s[5]);
if s[2] = '-' then a := -a;
writeln(b - a);
end
else if s[3] = 'x' then begin
a := StrToInt(s[1]);
b := StrToInt(s[5]);
if s[2] = '-' then begin
a := -a;
b := -b;
end;
writeln(b - a);
end
else if s[5] = 'x' then begin
a := StrToInt(s[1]);
b := StrToInt(s[3]);
if s[2] = '-' then
b := -b;
writeln(a + b);
end
end.
учтите что никакой защиты от дурака или неверного ввода