В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mishakukla
mishakukla
28.04.2020 05:06 •  Информатика

Cоставить алгоритм и написать программу. найдите дискриминант квадратного уравнения: y=5x^2+6x-7

Показать ответ
Ответ:
lyababaranik
lyababaranik
06.07.2020 21:15
#include <iostream>
#include <math.h>

using namespace std;

int main()
{
    float a,b,c;
        int d;
        float x1, x2;

        cout << "ax^2+bx+c=0" << endl;
        cout << "Input a:" << endl;
        cin >> a;
        cout << "Input b:" << endl;
        cin >> b;
        cout << "Input c:" << endl;
        cin >> c;
        d= sqrt(b*b-4*a*c);
        x1=((-1)*b+d)/(2*a);
        x2=((-1)*b-d)/(2*a);
        cout << "x1=" << x1 << endl;
        cout << "x2=" << x2 << endl;
    return 0;
}

Но есть корень из дискриминанта нормально не получится - оно не напишет тебе + √13 допустим, он посчитает корни приблизительно.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота