В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

CРОЧНО РЕШИТЬ НА Python 3 Через 'for i in range' без 'abs,while'

Даны натуральное число n и вещественные числа b1, b2, ..., bn. Определите сумму тех вещественных чисел, которые больше заданного p.

Формат входных данных
Вводятся целое число n (1≤n≤1000), вещественные числа p, b1, ..., bn, которые не превосходят по модулю 105, заданы с двумя знаками после запятой

Требуется вывести искомую сумму

входные данные:
5
2.44
1.66
-1.66
66.72
123.45
-66.13
выходные данные:

190.170000

Показать ответ
Ответ:
Алия0051
Алия0051
03.06.2020 14:19
Program pr;
uses crt;

Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;

Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);

if (M>1000) or (N>1000) or (M<1) or (N<1)
then  
Writeln('Ошибка, указанные значения выходят за пределы матрицы')   else   
        Begin      
 Writeln('Введите элементы матрицы');      

k:=0; 
 for i:=1 to N do     
  for j:=1 to M do     
    Begin     
      readln(mas[i,j]);       
      if (mas[i,j] mod 2 = 0) then k:=k+1;     
    end; 
  
    Writeln();   
    Writeln('Исходная матрица');
   
   for i:=1 to N do   
     Begin     
       for j:=1 to M do     
          Begin     
             Write(mas[i,j], ' ')     
           end;     
      Writeln();   
     end;         

Writeln();   
Writeln('Количество четных элементов = ',k);      
 end;

readln;
end.
0,0(0 оценок)
Ответ:
рубін
рубін
16.02.2022 17:30

такие деформации, которые, во-первых, выражают несправедливость социального устройства, открывают простор для произвола одних субъектов в ущерб другим; во-вторых, ущемляют права и свободы граждан, а в-третьих, ведут к дегуманизации и ущербности социального статуса и менталитета части населения.

Кроме того, в нашей стране имеются и правовые рычаги защиты как государственных интересов, так и интересов каждого гражданина от киберпреступности. И это несмотря на то, что ни административное, ни уголовное законодательство не предусматривают ответственности за совершение именно киберпреступлений.

Это обусловлено тем, что хотя киберпреступления и совершаются с компьютеров, компьютерных систем и сетей и в виртуальной среде, тем не менее они выходят на физический уровень и причиняют материальный вред, а, значит, посягают на реальные правоотношения, затрагивают интересы конкретных людей, приносят негативные последствия. В связи с этим к данным преступлениям применимы и существующие нормы административного и уголовного законов, действующих на территории Российской Федерации.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота