В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Cроки поджимают на С++ написать программу: Бот не должен наносить урон убитому игроку.
Бот не должен наносить атаку убитым игроком.
Игрок не должен наносить урон убитому игроку.
Игрок не должен наносить атаку убитым игроком.

Показать ответ
Ответ:
6ytq3j5uhGBQ
6ytq3j5uhGBQ
01.01.2021 12:57

Всемирная компьютерная сеть (или Интернет) — это объединение локальных, региональных и национальных компьютерных сетей в одно информационное пространство, которое не имеет никаких территориальных и национальных границ. В современном мире интернет представляет собой глобальное средство коммуникаций, которое эффективно обеспечивает обмен различной информацией: Текстовые файлы; Изображения и графика; Аудиофайлы; Видеоинформация; Онлайновые службы по всей планете. На сегодняшний день количество пользователей сети интернет уже давно превысило отметку в 1 миллиард человек. По оценке Всероссийского центра изучения общественного мнения (ВЦИОМ) сегодня в России количество пользователей интернетом перевалило за 70% всего населения, что является достаточно высоким показателем, учитывая процентное соотношение представителей разных возрастов. Информация взята с сайта биржи Автор24: https://spravochnick.ru/informacionnye_tehnologii/organizaciya_kompyuternyh_setey/vsemirnaya_kompyuternaya_set/ .

Взято со страницы: https://spravochnick.ru/informacionnye_tehnologii/organizaciya_kompyuternyh_setey/vsemirnaya_kompyuternaya_set/

0,0(0 оценок)
Ответ:
aleshibin
aleshibin
02.08.2021 16:20

#include<conio.h>

#include<stdio.h>

#include <stdlib.h>

#include<time.h>

#define N 25

#define K 3

 

int prime(int num)

{   int i;

   for(i=2;i<=num/2;i++)

       if(num%i==0) break;

   if(i==num/2+1 || num==1) return num;

   else return 0;

}

 

int maxPos(int A[])

{   int i,max,mPos;

   max=0;

   for(i=0;i<N;i++)

       if(A[i]>max)

       {   max=A[i];

           mPos=i;

       }

   return mPos;

}

 

int main()

{   int i,j,X[N],Y[N],pos;

   srand(time(NULL));

   for(i=0;i<N;i++)

   {   X[i]=rand()%30+1;

       Y[i]=prime(X[i]);

   }

   printf("Original array\n");

   for(i=0;i<N;i++)

       printf("%3d",X[i]);

   printf("\nArray-masque of prime numbers\n");

   for(i=0;i<N;i++)

       printf("%3d",Y[i]);

   

   printf("\n\n");

   for(j=0;j<K;j++)

   {   pos=maxPos(Y);

       printf("%3d in position %3d targeted\n",X[pos],pos);

       Y[pos]=-1;

       X[pos]=-1;

   }

 

   j=0;

   for(i=0;i<N;i++)

       if(X[i]!=-1)

       {   Y[j]=X[i];

           j++;

       }

   

   printf("\nResult:\n");

   for(i=0;i<j;i++)

       printf("%3d",Y[i]);

   

   getchar();

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота