В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tasapetrova
tasapetrova
21.04.2021 05:46 •  Информатика

ДАМ ЗА РЕШЕНИЕ

Задача 1

Составить программу, которая по номеру месяца выводит время года.

Например:

N=1

Зима

Задание 2

Составить программу, которая определяет температуру человека по введенному значению:

• Меньше 34 или более 41: не может быть

• От 34,1 до 36,4: пониженная

• От 36,5 до 36,6: нормальная

• От 36,7 до 41: повышенная

И ВСЁ В ПАСКАЛЬ

Показать ответ
Ответ:
Coul2000nator
Coul2000nator
15.10.2020 02:27

1)

var n:integer;

begin

  writeln('Введите номер месяца: ');

 readln(n);

 if (n = 1) or (n = 2) or (n = 12) then

   writeln('Зима');

 if (n = 3) or (n = 4) or (n = 5) then

   writeln('Весна');

 if (n = 6) or (n = 7) or (n = 8) then

   writeln('Лето');

 if (n = 9) or (n = 10) or (n = 11) then

   writeln('Осень');

end.

2)

var n:real;

begin

  writeln('Введите температуру: ');

 readln(n);

 if (34.1 <= n) and (n <= 36.4) then

   writeln('Пониженная');

 if (36.5 <= n) and  (n<= 36.6) then

   writeln('Нормальная');

 if (36.7 <= n) and (n <= 41) then

   writeln('Повышенная');

  if (n <= 34) or (n > 41) then

   writeln('Не может быть!');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота