Дан алгоритм и Составьте программу на языке программирования. Запишите ниже алгебраический пример начало x=5, y=-6 если (x больше y), то z=y-x иначе z=y-x вывод z конец
Устройство ввод-периферийное оборудование для занесения (ввода) данных или сигналов в компьютер либо в другое электронное устройство во время его работ/Сканер,Видео-и Веб-камера,Цифровой фотоаппарат,Плата видеозахвата,Микрофон,Цифровой диктофон,Мышь,Трекбол,Тачпад,Световое перо,Графический планшет,Тачскрин,Джойстик,Устройства основанные на компьютерном зрении типа Kinect. Устройство вывода - периферийные устройства, преобразующие результаты обработки цифровых машинных кодов в форму, удобную для восприятия человеком или пригодную для воздействия на исполнительные органы объекта управления. Монитор (дисплей),Принтер,Графопостроитель(плоттер),Встроенный динамик,Колонки,Наушники
Const n=5; var i: integer; b: real; a: array [1..n] of integer; {если его элементы целые числа (про тип чисел ничего не сказано в задании)} begin for i:=1 to n do read(a[i]); if ((a[1]+a[3]) mod 5 = 0) and (a[5] mod 10 = 3) then begin b:=0; for i:=1 to 5 do b:=b+sqr(a[i]); end else begin b:=1; for i:=1 to 5 do b:=b*sqrt(a[i]); end; writeln(b:1:2); {округление до сотых} if (a[1]+a[2]+a[3])>15 then writeln('да, сумма 1, 2 и 3 чисел больше 15') else writeln('нет, сумма 1, 2 и 3 чисел меньше или равна 15'); if ((a[4]+a[5]) div 10>0) and ((a[4]+a[5]) div 100<0) then writeln('да, сумма 4 и 5 чисел - двузначное число') else writeln('нет, сумма 4 и 5 чисел - не двузначное число'); readln; {чтобы была задержка до нажатия кнопки при выполнении программы и мы могли бы увидеть ответ} end. Решить можно и без использования массива.
Устройство вывода - периферийные устройства, преобразующие результаты обработки цифровых машинных кодов в форму, удобную для восприятия человеком или пригодную для воздействия на исполнительные органы объекта управления.
Монитор (дисплей),Принтер,Графопостроитель(плоттер),Встроенный динамик,Колонки,Наушники
var i: integer;
b: real;
a: array [1..n] of integer; {если его элементы целые числа (про тип чисел ничего не сказано в задании)}
begin
for i:=1 to n do
read(a[i]);
if ((a[1]+a[3]) mod 5 = 0) and (a[5] mod 10 = 3) then
begin b:=0;
for i:=1 to 5 do
b:=b+sqr(a[i]);
end
else begin b:=1;
for i:=1 to 5 do
b:=b*sqrt(a[i]);
end;
writeln(b:1:2); {округление до сотых}
if (a[1]+a[2]+a[3])>15 then writeln('да, сумма 1, 2 и 3 чисел больше 15')
else writeln('нет, сумма 1, 2 и 3 чисел меньше или равна 15');
if ((a[4]+a[5]) div 10>0) and ((a[4]+a[5]) div 100<0) then writeln('да, сумма 4 и 5 чисел - двузначное число')
else writeln('нет, сумма 4 и 5 чисел - не двузначное число');
readln; {чтобы была задержка до нажатия кнопки при выполнении программы и мы могли бы увидеть ответ}
end.
Решить можно и без использования массива.