В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
henriksenkids
henriksenkids
22.05.2020 03:35 •  Информатика

Дан целочисленный массив. Элементы массива-целые числа , вводятся с клавиатуры. Найти произведение элементов этого массива и количество элементов кратных 3. Написать программу.​

Показать ответ
Ответ:
Nastya0bendy
Nastya0bendy
16.10.2021 12:33
{ s(трапеции) = ((a+b)/2)*h; }
uses crt;
var
a, b, h: Integer; (Real)
s: Real;
begin
WriteLn('Введите а: ',a);ReadLn(a);
WriteLn('Введите b: ',b);ReadLn(b);
WriteLn('Введите h: ',h);ReadLn(h);
s:= ((a+b)/2)*h;
WriteLn('S = ', s);
ReadLn;
end.
Если же а и б должны быть обязательно меньше h, то:
if (a < h) and (b < h) then
begin
WriteLn('Введите а: ',a);ReadLn(a);
WriteLn('Введите b: ',b);ReadLn(b);
WriteLn('Введите h: ',h);ReadLn(h);
s:= ((a+b)/2)*h;
WriteLn('S = ', s);
ReadLn;
end;
else begin
WriteLn('Основания не меньше h!');
ReadLn;
end;
0,0(0 оценок)
Ответ:
ОСЕНЬ2019
ОСЕНЬ2019
25.10.2021 15:02
Кое что убрал - работает, только свои данные введи (фамилия и т.д.)

uses graphabc;var s,f,i,o: string;    j: byte;    pic: integer;begin
s:='AVALON';f:='FAMILY';i:='name';o:='second name';
setfontcolor(clred);setwindowsize(550,250);setfontsize(20);setfontstyle(fsbold);for j:=1 to length(s) do    textout(10,(j*40)-40,s[j]);setpencolor(clred);setbrushcolor(clred);rectangle(30,120,550,125);setfontcolor(clblue);setbrushcolor(clwhite);setfontname('Tahoma');setfontsize(16);SetFontStyle(fsnormal);textout(300,10,f);SetFontStyle(fsItalic);textout(300,50,i);textout(300,90,o);setpenwidth(6);for j:=1 to 10 do    arc(500+(j*30),420,300,0,180);setfontname('Times');setfontsize(26);textout(40,150,'Something for good');end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота