В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
вгььсь
вгььсь
27.09.2021 20:49 •  Информатика

Дан целочисленный массив из 31 элемента, элементы массива могут принимать значения от -20 до 20. написать программу, которая выводит среднюю температуру среди дней, когда была оттепель.

Показать ответ
Ответ:
aliyaulanova1
aliyaulanova1
02.10.2020 09:52
Var a,b,i:integer;
n:real;
mass:array[1..31] of integer;
begin
for i:=1 to 31 do begin
mass[i]:=random(40)-20;
if mass[i]>0 then begin
b:=b+1;
a:=a+mass[i];
end;
end;
writeln('Полученные значения');
for i:=1 to 31 do
write(mass[i]:4);
n:=a/b;
writeln;
writeln('Средняя температура равна ',n:3:1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота