В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
madishalabaev
madishalabaev
24.02.2023 17:11 •  Информатика

Дан целочисленный массив из 7 элементов, в котором записаны значения температуры воздуха за неделю. Элементы массива могут принимать значения от (–10) до 0. Составьте программу, которая подсчитывает и выводит номер дня недели, когда температура была максимальной.

Показать ответ
Ответ:
shcherbakova05
shcherbakova05
09.12.2020 18:43

var

 temp:array [1..7] of shortint;

 i,max:byte;

begin

 randomize;

 for i:=1 to 7 do temp[i]:=random(10)-10;

 max:=1;

 for i:=2 to 7 do if temp[i]>temp[max] then max:=i;

 writeln(max);

end.  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота