В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
vlastovskii
vlastovskii
25.01.2023 06:24 •  Информатика

Дан целочисленный массив состоящий из элементов, элементы массива принимают значение от 0 до 100. составьте программу для вычисления произведения элементов массива, которые не четны и делятся на 3.

Показать ответ
Ответ:

const n=10;
var
a:array [1..n] of integer;
i,s:integer;
begin
Randomize;
for i:=1 to n do
begin
  a[i]:=random(100);
  write(a[i],' ');
end;
for i:=1 to n do if (a[i] mod 2 =1) and (a[i] mod 3 =0) then if s=0 then s:=a[i] else s:=s*a[i];
writeln;
writeln(s);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота