Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Элинка235
16.06.2020 08:00 •
Информатика
Дан числовой массив а, состоящий из n натуральных чисел. определите количество элементов массива, которые при делении на 7 остаток 1, 2 или 5.
Показать ответ
Ответ:
гулие
02.10.2020 22:11
Const
N = 7;
Var
A:array[1..N] of integer;
i,j:integer;
Begin
j:=0;
WriteLn('Введи массив A(N)');
For i:= 1 to N do
Begin
Read(A[i]);
if (A[i] mod 7 =1)or(A[i] mod 7 =2)or(A[i] mod 7 =5) then j:=j+1
End;
WriteLn(j)
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
sasasnikas
09.06.2020 01:19
Дан фрагмент линейного алгоритма.Чему равно значение переменной а после его исполнения? а:=10 b:=5-2*a a:=b/5*a...
damnit
09.08.2021 01:01
.Скорость передачи данных через АDSL-соединение равна 600000 бит/с. Через данное соединение передают файл размером 1200 Кб. Определите время передачи файла в секундах....
taskarin02
26.09.2020 06:05
При интернет-соединении с максимальной скоростью передачи данных 192кбит/с аудиофайл размером 3600 кбайт будет в лучшем случае передаваться а) 5мин б)больше15 в)10мин г)2,5мин...
777angel777likoy8mjs
22.11.2021 22:17
Работа № 2. 1. алфавит племени мульти состоит из 32 букв. какое количество информации несёт одна буква этого алфавита? 2. сообщение, записанное буквами из 16-символьного алфавита,...
dogsno
28.08.2022 12:53
В каком режиме документ выглядит так, как он выглядел бы распечатанным на принтере а) режим структуры б)режим разметки в)обычный режим Что такое электронная таблица? а) это двумерный...
belka1006
26.02.2022 08:42
Назовите тип информационного процесса в следующих ситуациях:А) дорожный знак предупреждает о ремонтных работахБ) Фотографии напомнили о хорошо проведенных каникулахВ) Учитель...
Саша13398
03.06.2023 18:53
Написать и отладить программу по следующему условию: Найти наибольший и наименьший элементы квадратной матрицы 5х5 и поменять их местами....
dashechka1707
03.12.2022 23:04
1 My dad works in Office, but he plays rugby at the weekend..FC Kairat is one of the most famousfootball teams in Almaty, Kazakhstan.3 He wants to swim across Ural River. Itflows...
Gafana
03.12.2022 23:04
Task 1. Choose the suitable word(s). Keep in mind that only one variant is correct.1) A: Hullo, Tony. Where 11 you been?B: We ve 12 back from a holiday 13 the country.A: When...
Студентка16епта
03.12.2022 23:04
Сочинение фазиль искандер петух или время по часам...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
N = 7;
Var
A:array[1..N] of integer;
i,j:integer;
Begin
j:=0;
WriteLn('Введи массив A(N)');
For i:= 1 to N do
Begin
Read(A[i]);
if (A[i] mod 7 =1)or(A[i] mod 7 =2)or(A[i] mod 7 =5) then j:=j+1
End;
WriteLn(j)
End.