В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
vgoidin
vgoidin
20.02.2021 05:34 •  Информатика

Дан двухмерный массив "у" с размерностью n x m если все элементы строки четные, то вывести порядковый номер строки. в паскале написать программу

Показать ответ
Ответ:
gaglovev2001
gaglovev2001
22.07.2020 07:23
Var
  y:array[1..999, 1..999] of integer;
  i, j, n, m:integer;
  chet:boolean;

begin
  randomize;
  readln(n, m);
  //Рандомно заполняем и выводим двумерный массив числами от 0 до 100
  for i:=1 to n do
  begin
    for j:=1 to m do begin
      y[i, j]:=random(101);
      write(y[i, j],' ');
    end;
    writeln;
  end;
  writeln;
  for i:=1 to n do
  begin
    chet:=true;
    for j:=1 to m do
      if y[i, j] mod 2 <> 0 then
        chet:=false;
    if chet = true then
      write(i, ' ');
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота