В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
HamstersLOKKI
HamstersLOKKI
29.10.2021 00:46 •  Информатика

Дан двумерный целочисленный массив а(m; n)состоящий из случайных чисел от (-20; 20).найти числа в1,,равные наименьшим значением строк.написать программу в паскале

Показать ответ
Ответ:
handogin1999
handogin1999
01.10.2020 11:50
Uses crt;
const n=5;
m=5;
var a:array[1..n,1..m] of integer;
i,b,j,k:integer;
begin
randomize;
for i:=1 to n do
for j:=1 to m do
begin
a[i,j]:=random(40)-20;
write(a[i,j]:3);
end;
writeln;
k:=1;
b:=20;
repeat
for i:=k to k do
for j:=1 to m do
if (a[i,j]<b) then b:=a[i,j];
writeln(b);
inc(k);
b:=20;
until k>n;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота