В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
rauf2007
rauf2007
28.01.2021 23:48 •  Информатика

дан фрагмент электронной таблице из ячейки b3 в ячейку c2

2.Составить программу для нахождения значения переменной дан фрагмент электронной таблице из ячейки b3 в ячейку c22.Составить программ">

Показать ответ
Ответ:
azs194karelin
azs194karelin
17.09.2020 06:07
Предполагается, что восьмеричное число записано, как символьная строка, поскольку максимальная разрядность не была оговорена в задании.

const
  m:array['0'..'7'] of string=
      ('000','001','010','011','100','101','110','111');
  m1:array['1'..'7'] of string=
      ('1','10','11','100','101','110','111');
var
  s8,s2:string;
  i:integer;
begin
  Write('Введите восьмеричное число: '); Readln(s8);
  s2:=m1[s8[1]];
  for i:=2 to Length(s8) do s2:=s2+m[s8[i]];
  Writeln('В двоичной системе: ',s2)
end.

Тестовое решение:
Введите восьмеричное число: 360721
В двоичной системе: 11110000111010001
0,0(0 оценок)
Ответ:
томирис1222233
томирис1222233
27.01.2022 16:05
Простейший вариант программы, предполагающий, что строка записана абсолютно верно и содержит только числа, соединенные знаком "плюс".

const
  digits=['0'..'9'];
var
  s,sn:string;
  i,err:integer;
  n,sum:longint;

begin
  Write('Введите числа, соединяя их знаком плюс: ');
  Readln(s);
  i:=2; sn:=s[1]; sum:=0;
  while i<=Length(s) do begin
    if s[i] in digits then sn:=sn+s[i]
    else begin
      Val(sn,n,err);
      sum:=sum+n;
      sn:=''
    end;
    Inc(i)
  end;
  Val(sn,n,err);
  sum:=sum+n;
  Writeln('Сумма равна ',sum)
end.

Тестовое решение:
Введите числа, соединяя их знаком плюс: 21+22+3
Сумма равна 46
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота