В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
yxurcguh
yxurcguh
12.04.2022 10:48 •  Информатика

Дан фрагмент текста , запрашиваемый у пользователя. написать программу, меняющую регистр всех букв на противоположный с#

Показать ответ
Ответ:
Тэхен10
Тэхен10
24.01.2023 04:07
#include <iostream>
#include <math.h>
#include <cstdlib>
using namespace std;

int main()
{
   int position = 0;

    int i,j, ch,a,s;
    int* mass = NULL;
    cout << "Заданное число А: ";
    cin >> a;

    while (1)

    {
        cin >> ch;
        if (ch == 0) break;
        mass = (int*)realloc(mass, (position+1)*sizeof(int));
        mass[position] = ch;
        position++;

    }
    s=0;
    j=0;
    for (i=0;i<position;i++){
        if (((mass[i] > 0) && (mass[i+1] > 0)) || ((mass[i] < 0) && (mass[i+1] < 0)))
            j++;
        if (((mass[i] > 0) && (mass[i] < a)))
            s++;
    }

    cout << "Номер поседней пары: " << j << endl;
    cout << "Положительно и не больше А: " << s << endl;

    return 0;
}
0,0(0 оценок)
Ответ:
ExDragon
ExDragon
23.10.2022 08:45
Цикл с предусловием это такой цикл, в котором условие проверяется перед выполнением тела цикла.
А цикл с постусловием - на оборот, он сначала выполнит, а потом проверит условие и если условие true, то цикл завершится.

Цикл с постусловием, можно использовать в таких ситуациях, когда надо что-то сделать и если чего-то не хватает, то сделать еще раз. Напрмер отправить письмо на email, а если не отправилось, то повторить еще 3 раза. Сначала выполнится тело цикла, в котором находятся функции отправки письма и если отправка удачная, то сообщаем until() true. Иначе тело выполнится еще и еще и еще кучу раз, если мы не задали счетчик в теле цикла, как вариант...

Цикл с предусловием можно использовать, если надо проверять какое-то значение ПЕРЕД выполнением тела цикла и тебе не важно, должно ли оно хоть раз выполниться. Например запросить пароль у пользователя. Но если пользователь уже ввёл пароль, то зачем его запрашивать? Тут можно было бы использовать while
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота